Error: “Failed to retrieve data from database.” ?

Error: “Failed to retrieve data from database.” ?

Sophia Asked on December 9, 2017 in Sage.
Add Comment
  • 1 Answer(s)

    Issue Resolution:

    Note: Sage no longer supports connecting Crystal Reports with Sage 50—US Edition nor troubleshoots customized reports.  Crystal Reports will still work with Sage 50—US Edition.

    Section I: Set Database Location

    1. Setup the ODBC Connection. Follow Article ID 12693 (How do I connect to the program using ODBC/OLEDB?)
    2. Inside Crystal Reports: select Database, click Set Database Location
    3. Select the new connection created above
    4. Click Update
    5. Run Report
    6. Go to File & Save  the report in order for it remember the connection

    Section II: Report Options

    1. Open the report you need to run
    2. Go to File, Report Options
    3. Deselect Uses Indexes Or Server For Speed
    4. Click OK
    5. Verify you can now run the report

    Resolution for Issue ‘Error: “Failed to retrieve data from database.”’ available: Yes (Solved).
    Source: Sage Community forums.
    Disclaimer: Sage Accounting Solution is an independent provider of Sage related services and is not affiliated with Sage or Intuit.

    Error: “Failed to retrieve data from database.”: this issue or error code is a known issue related to Sage accounting products. Support for this issue is available either by self-service or paid support options. Experts are available to resolve your Sage issue to ensure minimal downtime and continue running your business. First try to resolve the issue yourself by looking for a resolution described below. If you are experiencing too many issues, you may want to export Sage 50 to Quickbooks.

    See also: transition from Sage 50 Quantum to Sage 50 Pro/Premium or transition from Sage. If it is a complex issue or you are unable to solve the issue, you may contact us by Sage Support Phone Number at 1 888 489 0694 or by using other Sage Support options.

    Support Team Answered on December 9, 2017.
    Add Comment
  • Your Answer

    By posting your answer, you agree to the privacy policy and terms of service.