Error: “Database engine timed out while serving the connection”

Error: “Database engine timed out while serving the connection”

Support Team Asked on December 28, 2017 in Sage.
Add Comment
  • 1 Answer(s)
    Resolution
     

    Option I:

    1. Configure firewall and/or antivirus to allow/exclude Sage 50 Accounting and MySQL database. For file names and locations that need to be allowed.
    2. Open the connection manager and set the following in the Advanced Database Settings section:
      • Memory buffer size (in MB): 128
      • Number of connection attempts: 6
    3. Downgrade the MySQL ODBC connector from 3.51.28 to 3.51.19.
      • If you cannot find the MySQL ODBC connector under Control Panel, Program and Features, uninstall and reinstall Sage 50.
    4. Reboot the computer.
    5. Try to re-open Sage 50.
    6. Open the sample company. If the “Database engine timed out” error occurs again, reinstall Sage 50 Accounting with the antivirus and firewall disabled.

    Option II:

    If 2013 opens and 2014 generates errors, the local host has been corrupted.

    Option III:

    1. Open the Windows Task Manager
    2. Verify that the CPU and Memory usage is not at 100% 
    3. If usage is at 100%.

    Source: Sage Community forums.

    Disclaimer: Sage Accounting Solution is an independent provider of Sage Related services and is not affiliated with Sage.

    See More: Support for this issue is available either by self-service or paid support options. Experts are available to resolve your Sage issue to ensure minimal downtime and continue running your business. First try to resolve the issue yourself by looking for a resolution described below. If you are experiencing too many issues, you may want to more info Call Sage Technical Support Number

    Support Team Answered on December 28, 2017.
    Add Comment
  • Your Answer

    By posting your answer, you agree to the privacy policy and terms of service.